Here is
/etc/config/network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'
option type 'bridge'
option ifname 'eth0.1'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'

config device 'lan_dev'
option name 'eth0.1'
option macaddr '78:a3:51:16:da:88'

config interface 'wan'
option ifname 'eth0.2'
option proto 'none'

config device 'wan_dev'
option name 'eth0.2'
option macaddr '78:a3:51:16:da:89'

config interface 'wan6'
option ifname 'eth0.2'
option proto 'none'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 1 2 3 6t'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '4 6t'

Cheers

Ilario Gelmetti <iochesonome@gmail.com> schrieb am Fr., 14. Apr. 2017 um 00:55 Uhr:
On 04/13/2017 09:23 PM, Juergen Kimmel wrote:
> After changing line 307 here output of lime-config:
>
> root@LiMe-16da88:~# lime-config
> /usr/lib/lua/lime/network.lua:155: attempt to index local 'dev' (a nil
> value)
>
>     On 13/04/17 17:59, Ilario Gelmetti wrote:
>     > If after this and a lime-config and a reboot things are not fixed can
>     > you post the output of
>     >
>     > uci show network
>     >
>     > (there could be some non "lm_net_" entry of type "device" that usually
>     > is not present in ar71xx hardware)

Ok, post your

uci show network

If there's some not "network.lm_net_*" entry which is of type "device"
(not "interface") missing "name" or "ifname" options, that could rise
the error you see.
Let us know :)
Ilario

_______________________________________________
lime-users mailing list
lime-users@lists.libremesh.org
https://lists.libremesh.org/mailman/listinfo/lime-users